Register

ViewletCentral does not report views as "completed"

Tips & Tricks for both Qarbon hosted and Self-Hosted

Moderators: James, Rado

Site Admin
User avatar
Posts: 51
Joined: Sat May 27, 2006 1:27 am
Location: Dolny Kubin, Slovakia

ViewletCentral does not report views as "completed"

Postby Rado » Mon Sep 10, 2007 6:48 am

Question: I have people going through my viewlet hosted on ViewletCentral, and they complete the viewlet by going to the last slide. However, on ViewetCentral, it is not showing that they have completed the viewlet, nor is it showing the time it took to complete the viewlet.


Problem: This usually happens if the Viewlet does not get a chance to tell ViewletCentral that it was completed, for example if you place a button on the last slide, allowing the visitors to close the viewlet or to jump to another website. Another situation when this can occur is if the last slide contains a Pause Zone, or if it's duration is too long (tens of seconds).

Solution: There is an easy solution to this problem in ViewletBuilder5 and ViewletQuiz. If you are creating a button with a "Close Viewlet" or "Display URL" action, you just have to make sure that you also add a "Submit Score" action to this button, and that the "Submit Score" action is first in the list of actions.

In case your last slide's duration is too long, you may add the "Submit Score" action to the "On Load" event of the last slide - this way visitors will be reported to have completed the viewlet as soon as they reach the last slide, without the need to wait until the last slide completes. To avoid issues, you also should not place a Pause Zone on the last slide of the viewlet, unless necessary.

Return to FAQs - VCL

Who is online

Users browsing this forum: No registered users and 1 guest